summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2021-08-09 22:15:58 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2021-08-09 22:24:43 +0200
commit2f510c5632ba83b97c6eb86ebf5e39085fde74fe (patch)
treef4351d26a3a81d24a281e2079bfc7e841ee7ff82 /CMakeLists.txt
parent6442107478c5418cd0053eef626f53d565fda7e1 (diff)
Bump to C++17
Comparison operators need to be const-invocable now, but otherwise no change seems necessary.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec2ec066f..deaebc72f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,7 @@ add_definitions(${LFS_DEFINITIONS})
link_libraries(${LFS_LIBRARIES})
# Set compiler flags
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)