summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2022-04-21 01:45:45 +0200
committerDavid Kalnischkies <david@kalnischkies.de>2022-05-07 10:45:44 +0200
commit8d8b45a96ceceb015f7836cf25b99279c2f377b9 (patch)
tree93a497556cdfac9332afbeeffdaf9f8a0485e9b2 /CMakeLists.txt
parentee06eb541e5aa477880ff0fc575be317eccbd929 (diff)
Link interactive helpers against system libapt for autopkgtest
Building the library just so we can build the helpers against it is not only wasteful but as we are supposed to test the system we can use that as an additional simple smoke test before the real testing starts.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c6896387..7f3a6a7c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -240,8 +240,10 @@ configure_file(CMake/apti18n.h.in ${PROJECT_BINARY_DIR}/include/apti18n.h)
# Add our subdirectories
add_subdirectory(vendor)
+if (NOT USE_SYSTEM_APTPKG)
add_subdirectory(apt-pkg)
add_subdirectory(apt-private)
+endif()
add_subdirectory(cmdline)
add_subdirectory(completions)
add_subdirectory(doc)