summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2022-04-19 13:06:44 +0200
committerDavid Kalnischkies <david@kalnischkies.de>2022-05-07 10:45:44 +0200
commitcd92098caa64b7fd30cdc6b5d56bf7e9e17a449e (patch)
tree10e772fda1e49ef65089e51f17f2a700f597eb2c /CMakeLists.txt
parent725fef5ebf45d03fea75866e9795717bf576d26a (diff)
Avoid building all docs in nodoc build profile
Differentiating between different types of documentation we build helps in better expressing what needs to be done for our arch:any and arch:all packages currently as well.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86e5060d1..5c6896387 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,12 @@ include_directories(${PROJECT_BINARY_DIR}/include)
enable_testing()
-option(WITH_DOC "Build documentation." ON)
+option(WITH_DOC "Build all documentation." ON)
+include(CMakeDependentOption)
+cmake_dependent_option(WITH_DOC_MANPAGES "Force building manpages." OFF "NOT WITH_DOC" OFF)
+cmake_dependent_option(WITH_DOC_GUIDES "Force building guides." OFF "NOT WITH_DOC" OFF)
+cmake_dependent_option(WITH_DOC_DOXYGEN "Force building doxygen documentation." OFF "NOT WITH_DOC" OFF)
+cmake_dependent_option(WITH_DOC_EXAMPLES "Force building example configurations." OFF "NOT WITH_DOC" OFF)
option(WITH_TESTS "Build tests" ON)
option(USE_NLS "Localisation support." ON)
@@ -247,7 +252,9 @@ add_subdirectory(test)
if (USE_NLS)
add_subdirectory(po)
+endif()
+if(TARGET update-po AND TARGET update-po4a)
# Link update-po4a into the update-po target
add_dependencies(update-po update-po4a)
endif()