summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2022-04-19 13:06:44 +0200
committerDavid Kalnischkies <david@kalnischkies.de>2022-05-07 10:45:44 +0200
commitcd92098caa64b7fd30cdc6b5d56bf7e9e17a449e (patch)
tree10e772fda1e49ef65089e51f17f2a700f597eb2c /doc/CMakeLists.txt
parent725fef5ebf45d03fea75866e9795717bf576d26a (diff)
Avoid building all docs in nodoc build profile
Differentiating between different types of documentation we build helps in better expressing what needs to be done for our arch:any and arch:all packages currently as well.
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 3060949e5..72a1fed88 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,4 +1,6 @@
+if (WITH_DOC OR WITH_DOC_MANPAGES OR WITH_DOC_GUIDES)
include(Documentation)
+endif()
set(LINGUAS
de
@@ -21,7 +23,7 @@ set(ENTITIES
../vendor/${CURRENT_VENDOR}/apt-vendor.ent
)
-if(WITH_DOC)
+if(WITH_DOC OR WITH_DOC_GUIDES)
add_docbook(apt-doc HTML TEXT ALL
DOCUMENTS
guide.dbk
@@ -43,7 +45,9 @@ add_docbook(libapt-pkg-doc HTML TEXT ALL
TRANSLATED_ENTITIES ${TRANSLATED_ENTITIES}
DEPENDS ${ENTITIES}
)
+endif()
+if(WITH_DOC OR WITH_DOC_DOXYGEN)
find_package(Doxygen REQUIRED)
file(GLOB_RECURSE apt_pkg "../apt-pkg/*.h" "../apt-pkg/*.cc")
@@ -65,9 +69,9 @@ install(DIRECTORY ${PROJECT_BINARY_DIR}/doc/doxygen/html
PATTERN "*.map" EXCLUDE
PATTERN "*.md5" EXCLUDE
)
-
endif()
+if(WITH_DOC OR WITH_DOC_MANPAGES)
add_docbook(apt-man MANPAGE ALL
DOCUMENTS
apt.8.xml
@@ -93,7 +97,12 @@ add_docbook(apt-man MANPAGE ALL
TRANSLATED_ENTITIES ${TRANSLATED_ENTITIES}
LINGUAS ${LINGUAS}
)
+endif()
+if(WITH_DOC OR WITH_DOC_MANPAGES OR WITH_DOC_GUIDES)
add_update_po4a(update-po4a po/${PROJECT_NAME}-doc.pot "po/header.pot.txt")
+endif()
+if(WITH_DOC OR WITH_DOC_EXAMPLES)
add_subdirectory(examples)
+endif()