summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2016-08-26 10:12:27 +0200
committerDavid Kalnischkies <david@kalnischkies.de>2016-08-26 10:38:27 +0200
commit53533ccccd7f7d4cd422e6ba33bb5d4c4d7f71b4 (patch)
tree3736806c4ef860dca7a2e6899da106e0c01bee54 /debian
parentea2de30794af69d5936dcfae033f80ca94299095 (diff)
use apt 1.3 directly instead of an embedded copy
APT 1.3 supports socks5h proxies out of the box now, so instead of using a copy of the -https transport as a proof of concept, we can now deligate all of the technical implementation details to APT via a few simple symlinks. Closes: #835128
Diffstat (limited to 'debian')
-rw-r--r--debian/control5
-rw-r--r--debian/copyright10
-rw-r--r--debian/links3
-rwxr-xr-xdebian/rules5
4 files changed, 8 insertions, 15 deletions
diff --git a/debian/control b/debian/control
index 4ac2252..5ef6bdf 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,14 @@ Source: apt-transport-tor
Section: admin
Priority: optional
Maintainer: Tim Retout <diocles@debian.org>
-Build-Depends: debhelper (>= 9), dh-autoreconf, libapt-pkg-dev, libcurl4-gnutls-dev
+Build-Depends: debhelper (>= 9)
Standards-Version: 3.9.5.0
Homepage: https://github.com/diocles/apt-transport-tor
Package: apt-transport-tor
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, tor
+Depends: apt (>= 1.3~rc1), tor, ${misc:Depends}, ${shlibs:Depends}
+Recommends: apt-transport-https
Description: APT transport for anonymous package downloads via Tor
Provides support in APT for downloading packages anonymously via the Tor
network.
diff --git a/debian/copyright b/debian/copyright
index a6de25f..950b2d5 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -3,8 +3,7 @@ Upstream-Name: apt-transport-tor
Source: https://github.com/diocles/apt-transport-tor/releases
Files: *
-Copyright: Copyright 2014 Tim Retout <diocles@debian.org>,
- 1997, 1998, 1999 Jason Gunthorpe and others.
+Copyright: Copyright 2014 Tim Retout <diocles@debian.org>
License: GPL-2+
This program is free software; you can redistribute it
and/or modify it under the terms of the GNU General Public
@@ -26,10 +25,3 @@ License: GPL-2+
On Debian systems, the full text of the GNU General Public
License version 2 can be found in the file
`/usr/share/common-licenses/GPL-2'.
-
-Files: debian/*
-Copyright: Copyright 2014 Tim Retout <diocles@debian.org>
-License: GPL-2+
- The Debian packaging is licensed under the same terms as
- apt-transport-tor itself; either release 0.1, or any later
- release you may have available.
diff --git a/debian/links b/debian/links
new file mode 100644
index 0000000..a2ffeca
--- /dev/null
+++ b/debian/links
@@ -0,0 +1,3 @@
+usr/lib/apt/methods/http usr/lib/apt/methods/tor
+usr/lib/apt/methods/http usr/lib/apt/methods/tor+http
+usr/lib/apt/methods/https usr/lib/apt/methods/tor+https
diff --git a/debian/rules b/debian/rules
index 63844c9..cbe925d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,3 @@
#!/usr/bin/make -f
-
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
%:
- dh $@ --with autoreconf
+ dh $@