summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2020-01-07 21:29:11 +0100
committerJulian Andres Klode <julian.klode@canonical.com>2020-01-07 21:32:23 +0100
commit01ff55f375b3d9e96b178d3a963d9e3d5ac5134b (patch)
tree4abb592bfd345b80208f9fe15f79d7548d2213d3 /CMakeLists.txt
parentf2ad6eb0c579f1c825aa1efec192b4d4eb5e6171 (diff)
Add support for GTest 1.9, do not fail silently if its missing
Require passing -DWITH_TESTS=OFF to CMakeList to disable unit tests, rather than ignoring them if GTest cannot be found; which just happened on CI...
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27222f648..ab08b8f4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,7 @@ include_directories(${PROJECT_BINARY_DIR}/include)
enable_testing()
option(WITH_DOC "Build documentation." ON)
+option(WITH_TESTS "Build tests" ON)
option(USE_NLS "Localisation support." ON)
set(CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/CMake")