summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-08-22 13:11:00 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2019-08-22 13:11:00 +0200
commitb9127ca07c37288f16b1fdc267d3f106721ed301 (patch)
tree345c647a8776531245d50482e69c2c1f72978ef4 /CMakeLists.txt
parent489da40d56075efaa28bfdcfb7b02b3bcc222323 (diff)
srvrec: Use re-entrant resolver functions
This should probably make those functions thread-safe, which might be useful for some external users.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0487429c6..160f7f913 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,7 +186,7 @@ if (NOT HAVE_SIGHANDLER_T)
endif()
# Handle resolving
-check_function_exists(res_init HAVE_LIBC_RESOLV)
+check_function_exists(res_ninit HAVE_LIBC_RESOLV)
if(HAVE_LIBC_RESOLV)
set(RESOLV_LIBRARIES)
else()