summaryrefslogtreecommitdiff
path: root/apt-pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-08-13 19:15:19 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2020-02-26 20:34:54 +0100
commitdb678df196ccd8f9f6fb336706cf5701d1e53aa6 (patch)
treea7937ab9aba3556760f0040727066a84a41f0006 /apt-pkg/CMakeLists.txt
parentc38e0047d95305e5984e822f670055cde6aa5f6a (diff)
apt-pkg: default visibility to hidden
Diffstat (limited to 'apt-pkg/CMakeLists.txt')
-rw-r--r--apt-pkg/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/apt-pkg/CMakeLists.txt b/apt-pkg/CMakeLists.txt
index e9a629ccf..7e51b1775 100644
--- a/apt-pkg/CMakeLists.txt
+++ b/apt-pkg/CMakeLists.txt
@@ -66,6 +66,7 @@ target_link_libraries(apt-pkg
)
set_target_properties(apt-pkg PROPERTIES VERSION ${MAJOR}.${MINOR})
set_target_properties(apt-pkg PROPERTIES SOVERSION ${MAJOR})
+set_target_properties(apt-pkg PROPERTIES CXX_VISIBILITY_PRESET hidden)
add_version_script(apt-pkg)
# Install the library and the header files